Entries not loading for some opportunities
Incident Report for Simplifying Creative Submissions
Resolved
Loading of entries for administrators and judges is now fixed.
Posted Jul 19, 2022 - 18:00 UTC
Update
We have identified the issue to be linked to some Google Services going offline > https://status.cloud.google.com/incidents/fmEL9i2fArADKawkZAa2#guoaCiLrsny92g8eoeyR.

We are actively monitoring this issue and will keep you updated.
Posted Jul 19, 2022 - 16:00 UTC
Monitoring
Judges and administrators of opportunities cannot load entries. Instead, the page goes into an infinite loading cycle.

We are investigating the issue and will keep you updated.
Posted Jul 19, 2022 - 15:30 UTC
This incident affected: Zealous and Core Third-party Services (Servers).